Carregando...

Todos os bloqueadores de anúncios e plug-ins legados do Chrome deixarão de funcionar em junho de 2024

Google relatadoque desativará a API Manifest V2 no navegador Chrome, com o qual a maioria dos bloqueadores de anúncios e outras extensões existentes funcionam.

A empresa mudará completamente para o API Manifest V3. Os usuários não poderão instalar plug-ins legados da Chrome Web Store.

Eles começarão a ser desativados nas compilações Chrome Dev, Canary e Beta já em junho de 2024, com o lançamento do Chrome 127 e posterior.

Mesmo que os desenvolvedores atualizem suas soluções para o Manifest V3, suas extensões terão funcionalidade severamente limitada. Em particular, o mecanismo da API chrome.webRequest, que anteriormente permitia o bloqueio de dados, mudará. Agora será usado para coletar dados.

Na nova versão do “manifesto”, a API chrome.declarativeNetRequest é responsável pelo bloqueio. Ele não pode alterar todos os dados das solicitações de rede, como fez o Web Request (em particular, é usado no popular serviço uBlock Origin).

A V3 força os desenvolvedores de extensões a usar um sistema diferente chamado API declarativeNetRequest, no qual as extensões devem criar uma lista de bloqueio de endereços predefinidos para bloquear.

Por que isso é um problema? Porque o Manivest V3 permite que extensões executem apenas 30.000 regras, e a maioria das extensões de bloqueio de anúncios precisará executar pelo menos 300.000 regras para funcionar de maneira eficaz. Conseqüentemente, a eficiência de seu trabalho diminuirá significativamente.

explicação dos desenvolvedores do NordVPN

A mudança afetará não apenas o Google Chrome, mas também todos os navegadores baseados no mecanismo Chromium. Entre eles, por exemplo, Opera, Microsoft Edge, Vivaldi e outros. Portanto, para que os bloqueadores de anúncios funcionem corretamente, você terá que mudar seu navegador para outro.





😳 Quer mais? Consulte Mais informação no telegrama
🤔 Procurando uma resposta para uma pergunta? Vir para o Fórum


indefinido

iPhones.ru

O Google anunciou que desativará a API Manifest V2 no navegador Chrome, que é usada para operar a maioria dos bloqueadores de anúncios e outras extensões existentes. A empresa mudará completamente para o API Manifest V3. Os usuários não poderão instalar plug-ins legados da Chrome Web Store. Eles começarão a ser desativados nas versões Chrome Dev, Canary e Beta em junho…

  • Antes

    Finalmente a Black Friday no AliExpress. Obtenha um desconto de 270 rublos para cada 2.000 rublos